1065 A+B and C (64bit) (20)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

不看书都没注意到 题目取值范围2的63次方是闭区间...不看书都没注意到原来题目也没考虑到这一点...

作者简直不要太细心 好评!

代码是书上的,回头得好好学一下组成原理了...

#include<cstdio>

int main()
{
	int T,tcase=1;
	scanf("%d",&T);
	while(T--)
	{
		long long a,b,c;
		scanf("%lld%lld%lld",&a,&b,&c);
		long long res=a+b; 
		bool flag;
		if(a>0&&b>0&&res<0) flag=true;
		else if(a<0&&b<0&&res>=0) flag=false;
		else if(res>c) flag=true;
		else flag=false;
		if(flag==true){
			printf("Case #%d: true\n",tcase++);
		}else{			
			printf("Case #%d: false\n",tcase++);
		}	
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/nishigesb123/article/details/83218347