PAT-1065 A+B and C (64bit)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line “Case #X: true” if A+B>C, or “Case #X: false” otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目大意:接收三个数啊a, b, c,取值范围均为 [ 2 63 , 2 63 ),要求判断 *a+b>c *是否成立。

解决思路: 3个数字均可使用 long 型变量存储,需要注意的是可能出现溢出问题,所以要根据溢出规则进行判断。

  • 如果a,b均大于0,相加结果却小于0,则结果溢出,一定有a+b>c
  • 如果a,b均小于0,相加结果却大于0,则结果溢出,一定有a+b<c
  • 如果a,b异号,则没有溢出问题,直接比较大小即可
#include <cstdio>
int main(void) {
    int t, i;
    long a, b, c, d;

    scanf("%d", &t);
    for (i = 1; i <= t; i++) {
        scanf("%ld%ld%ld", &a, &b, &c);
        d = a + b;
        printf("Case #%d: ", i);
        if (a < 0 && b < 0 && d >= 0) {
            printf("false\n");
        }
        else if (a > 0 && b > 0 && d < 0) {
            printf("true\n");
        }
        else if (a + b > c) {
            printf("true\n");
        }
        else {
            printf("false\n");
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhayujie5200/article/details/79466874