zoj_2511 贪心

Design T-Shirt

Time Limit: 2 Seconds       Memory Limit: 32768 KB

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input:

3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2

Sample Output:

6 5 3 1
2 1

思路:   把每一个元素的评分加总, 按评分降序排一下,相同评分内部再按照序号升序排一下。
#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

struct dat
{
    float num;
    int index;
}data[1000000];

bool cmp(dat a, dat b)
{
    if(a.num != b.num)
        return a.num > b.num;
    else
        return a.index < b.index;
}

int main()
{
    int n,m,k;
    while(scanf("%d%d%d",&n,&m,&k)!=-1)
    {

        float temp=0;
        for(int i=0;i<m;i++)
        {
            data[i].num = 0;
            data[i].index = i;
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%f", &temp);
                data[j].num += temp;
            }
        }

        sort(data, data+m, cmp);

//        for(int i=0; i<m; i++)
//        {
//            printf("%f---%d\n", data[i].num, data[i].index);
//        }

        int ans[k+1000];

        for(int i=0; i<k; i++)
        {
            ans[i]=data[i].index+1;
        }
        sort(ans, ans+k, greater<int>());


        for(int i=0; i<k; i++)
        {
            if(i!=k-1)
                printf("%d ",ans[i]);
            else
                printf("%d\n", ans[i]);
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Dawn-bin/p/10796285.html
今日推荐