[贪心+模拟] zoj 3829 Known Notation

题目链接:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5383

Known Notation

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author:  CHEN, Cong
Submit     Status
题目意思:

给1~9和*组成的一个字符串,可以有两种操作添加一个数字或*,交换任意两个字符。求最少的步数使的式子为逆波兰式。

解题思路:
贪心+模拟

1、当数字个数小于等于*个数时,要加数字使得其个数为*的个数。

2、111*111这种情况答案为1,记录当前数字的最少个数和最多个数,*隔开的是两部分,数字不能连在一起,要分别加Mi,Ma。

3、如果前面数字不够,就把最后面的数字和当前的*交换,注意交换后可以和前面数字连成一片,是一个部分,所以此时Mi不能加。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 1100

char sa[Maxn];
int n;

int main()
{
    //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   int t;

   scanf("%d",&t);
   while(t--)
   {
       scanf("%s",sa+1);
       n=strlen(sa+1);
       int cnt1=0,cnt2=0;
       int la=0,Ma,Mi,p,ans=0;

       for(int i=1;i<=n;i++)
       {
           if(sa[i]=='*')
                cnt2++;
           else
                cnt1++;
       }
       if(cnt1<=cnt2)
       {
           ans+=cnt2+1-cnt1;
           la=cnt2+1-cnt1;
       }

       for(p=1;p<=n&&sa[p]!='*';p++)
       if(p>n)
       {
           printf("0\n");
           continue;
       }

       la+=p-1;
       Ma=la;
       if(la)  //注意这里区别一开始都是*的情况
            Mi=1;
       else
            Mi=0;
       //printf("Mi:%d Ma:%d la:%d p:%d\n",Mi,Ma,la,p);
       //system("pause");
       for(;p<=n;p++)
       {
           if(sa[p]=='*')
           {
               if(Ma<=1) //非得交换
               {
                   ans++;
                   for(int j=n;j>p;j--)
                   {
                       if(sa[j]!='*')//最后一定有数字,一定可以交换
                       {
                           swap(sa[p],sa[j]);
                           break;
                       }
                   }
                   int temp=0;
                   while(p<=n&&sa[p]!='*')
                        temp++,p++;
                   Ma+=temp;
                   if(!Mi)
                        Mi=1;  //为第一个  否则不能把Mi加一个,交换后可以连在一起的
                   p--;
               }
               else  //
               {
                   if(Mi>1)
                        Mi--;
                   Ma--;
               }
           }
           else
           {
               int temp=0;
               while(p<=n&&sa[p]!='*')
                   temp++,p++;
               Mi++;  //注意*隔开的两部分,不能连在一起,所以Mi要加一
               Ma+=temp;
               p--;
           }
       }
       ans+=Mi-1;
       printf("%d\n",ans);

   }
    return 0;
}
/*
111*111
1*11*11
*/



猜你喜欢

转载自blog.csdn.net/cc_again/article/details/40021989