hdu3709Balanced Number 数位DP加枚举

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2
0 9
7604 24324

Sample Output

10
897
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define ll long long
using namespace std;
int t;

ll dp[30][30][2005];
int bit[30];
ll dfs(int pos,int d,int sum,int limit)
{

    if(pos==-1)
        return sum==0;
        if(sum<0)
            return 0;
    if(!limit&&dp[pos][d][sum]!=-1)
        return dp[pos][d][sum];
    int up=limit?bit[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,d,sum+i*(pos-d),limit&&i==up);
    }
    if(!limit)
        dp[pos][d][sum]=ans;
    return ans;
}
ll solve(ll x)
{int pos=0;
    while(x)
    {
        bit[pos++]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int i=0;i<pos;i++)
        ans+=dfs(pos-1,i,0,1);
        return ans-pos+1;
}
int main()
{
    scanf("%d",&t);
      memset(dp,-1,sizeof(dp));
    while(t--)
    {
        ll l,r;

        scanf("%lld%lld",&l,&r);
        printf("%lld\n",solve(r)-solve(l-1));
    }
    return 0;

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89194748