HDU 3709 —— Balanced Number(数位dp)

Balanced Number

Time Limit:5000MS     Memory Limit:65535KB     64bit IO Format:%I64d & %I64u

Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2

0 9

7604 24324

Sample Output

10

897

1. 根据重心的性质,一个物体有且仅有一个重心,所以一个数也有且仅有一个重心。故,我们只需要枚举不同重心的平衡数个数,然后求和即可

2. 当我们没有限制,可以任意填写数字时(limit=0),如果剩下的等待填写的位数相同(u),重心pivot相同(计算力矩的公式一模一样),当前力矩torque(当前这一位前面也填写了若干位)也相同,则可以断定:即使我之前填写的数字是不一样的,最终填写完全后的平衡数的个数会是相同的!

    因此,dp[u][pivot][torque]的定义是正确的!

3.最后,要注意去掉全为0的重复的情况:)

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

typedef long long LL;
int a[20], sum[20];
LL dp[20][20][1710];
int len;

LL dfs(int u, int pivot, int torque, bool limit)
{
    if(u < 1)    return torque == 0;
    
    if(!limit && dp[u][pivot][torque] != -1)    return dp[u][pivot][torque];
    
    int maxn = limit ? a[u] : 9;
    LL ret = 0;
    int newT;
    for(int i=0; i<=maxn; i++) {
        newT = torque+(u-pivot)*i;
        if(newT >= 0)
            ret += dfs(u-1, pivot, newT, limit&&i==maxn);
    }
    if(!limit)    dp[u][pivot][torque] = ret;
    return ret;
}

LL f(LL x)
{
    len=0;
    while(x) {
        a[++len] = x%10;
        x /= 10;
    }
    LL ret = 0;
    for(int i=1; i<=len; i++) {
        ret += dfs(len, i, 0, 1);
    }
    return ret-len+1;
}

int main ()
{
    int T;
    LL x, y;
    scanf("%d", &T);
    memset(dp, -1, sizeof(dp));
    while(T--) {
        scanf("%lld%lld", &x, &y);
        printf("%lld\n", f(y) - f(x-1));
    }
    
    return 0;
}

转载自: https://blog.csdn.net/acisfun/article/details/51447673

猜你喜欢

转载自blog.csdn.net/no_o_ac/article/details/81148987