HDU 3709 Balanced Number(数位dp)

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7215    Accepted Submission(s): 3464


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
 
  
2 0 9 7604 24324
 

Sample Output
 
  
10 897

题解:
枚举以每一位为中心,中心左边加,右边减,最后若是0则满足条件

代码:
#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll dp[22][22][5005];
int a[22];
ll dfs(int pos,int id,int s,bool p)
{
    if(pos==-1)return s==0;
    if(s<0)return 0;
    if(!p&&dp[pos][id][s]!=-1)
        return dp[pos][id][s];
    int num=p?a[pos]:9;
    ll ans=0;
    for(int i=0;i<=num;i++)
    {
        ans+=dfs(pos-1,id,s+(pos-id)*i,p&&(i==num));
    }
    if(!p)
        dp[pos][id][s]=ans;
    return ans;
}
ll cal(ll x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int i=0;i<pos;i++)
        ans+=dfs(pos-1,i,0,1);
    return ans-pos+1;
}
int main()
{
    memset(dp,-1,sizeof(dp));
    ll x,y;int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&x,&y);
        printf("%lld\n",cal(y)-cal(x-1));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albertluf/article/details/80577788