大数加法>>HDU - 1250

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

大数加法 但一位一位存内存会超限 就多存几位= =

就大数加法题 为什么当时没过呢 因为看不懂英语啊 因为就一个样例就写了单组输入啊 多组输入的题单组怎么过呢 以后再也不写单组了!

#include <string.h>
#include<stdio.h>
using namespace std;
struct xxx
{
    int an[700];
    int ll;
} f[7100];
void pr(int a)
{
    int i;
    for(i=699; i>=0; i--)
    {
        if(f[a].an[i])
            break;
    }
    printf("%d",f[a].an[i]);
    for(i=i-1; i>=0; i--)
        printf("%.3d",f[a].an[i]);
    printf("\n");
}
void re(int a,int b,int c,int d,int e)
{
    int jin=0;
    for(int i=0; i<700; i++)
    {
        f[a].an[i]=f[b].an[i]+f[c].an[i]+f[d].an[i]+f[e].an[i]+jin;
        if(f[a].an[i]>999)
        {
            jin=f[a].an[i]/1000;
            f[a].an[i]=f[a].an[i]%1000;
        }
        else
            jin=0;
    }
    return ;
}
int main()
{
    memset(f,0,sizeof(f));
    for(int i=1; i<=4; i++)
    {
        f[i].an[0]=1;
    }
    for(int i=5; i<7100; i++)
    {
        re(i,i-1,i-2,i-3,i-4);
    }
    int n;
    while(~scanf("%d",&n))
    {
        pr(n);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43372531/article/details/88833227
今日推荐