【JAVA大数】Hat's Fibonacci HDU - 1250

题目链接

Hat’s Fibonacci HDU - 1250

题目

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

题意

给定一个递推公式,要求求第n位的指。值的位数不超过2005位。

分析

递推,O(n)级别算法,时间肯定不会超限。
然后调用JAVA的BigInteger包来解决大数问题就好了。

AC代码

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int n;
        while(cin.hasNext()) {
            n=cin.nextInt();
            BigInteger a,b,c,d,e;
            a=BigInteger.ONE;
            b=c=d=e=a;
            for(int i=5;i<=n;i++) {
                e=a.add(b).add(c).add(d);
                a=b;
                b=c;
                c=d;
                d=e;
            }
            System.out.println(e);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_37685156/article/details/80191878