pat 1041

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10
​4
​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10
​5
​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17
Sample Output 1:

31
Sample Input 2:

5 888 666 666 888 888
Sample Output 2:

None

代码
#include<stdio.h>
int a[100000]={0};
int main()
{
int n;
int x[100000];
int j;
int tmp=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&x[i]);
if(x[i]>tmp)
tmp=x[i];
a[x[i]]++;
}
for(j=0;j<n;j++)
{
if(a[x[j]]1)
{
printf("%d",x[j]);
break;
}
}
if(j
n)
printf(“None”);
}

猜你喜欢

转载自blog.csdn.net/qq_41474792/article/details/86668431
今日推荐