Codeup-问题 B: Hello World for U

题目描述

 

 

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

输入

 

 

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

 

输出

 

 

For each test case, print the input string in the shape of U as specified in the description.

 

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int main()
{
	char a[100];
	int i;
	gets(a);
	int n=strlen(a);
	int n2=(n+2)/3;
    int n1=n-2*(n2-1);
	for(i=0;i<n2-1;i++)
    {
        printf("%c",a[i]);
        for(int k=0;k<n1-2;k++)
            printf(" ");
        printf("%c\n",a[n-i-1]);
    }
    for(i=n2-1;i<n2-1+n1;i++)
        printf("%c",a[i]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Zizizi9898/article/details/88855664