Codeup-问题 B: Day of Week

题目描述

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入

21 December 2012
5 January 2013

样例输出

Friday
Saturday

对于这一题的基本思路就是,设置了一个结构体,用来存放输入的day,month,year,设置两个字符串数组,一个用来存放月份,其对应的索引用来代表具体月份的数字,还有一个数组用来存放星期,用于根据余数判断是星期几并输出,具体的星期计算公式见https://blog.csdn.net/Zizizi9898/article/details/88862103

具体代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

char month[13][10]={"0","January","February","March","April","May","June","July","August","September","October","November","December"};
char week[7][10]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};

struct Day
{
    int year;
    char month[20];
    int day;
}date;

int main()
{
    while(scanf("%d%s%d",&date.day,&date.month,&date.year)!=EOF)
    {
        int i,mon;
        for(i=1;i<13;i++)
        {
            if(strcmp(date.month,month[i])==0)
            {
                mon=i;
                break;
            }
            else
                continue;
        }
        int year;
        year=date.year;
        if(mon==1)
        {
            mon=13;
            year--;
        }
        if(mon==2)
        {
            mon=14;
            year--;
        }
        int w;
        w=(date.day+2*mon+3*(mon+1)/5+year+year/4-year/100+year/400+1)%7;
        printf("%s\n",week[w]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Zizizi9898/article/details/88862630
今日推荐