Codeup墓地—问题 B: Hello World for U

题目描述

 

 

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

输入

 

 

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

 

输出

 

 

For each test case, print the input string in the shape of U as specified in the description.

 

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor
#include <stdio.h>
#include <string.h>
int main()
{
    int len;
    char str[100];
    scanf("%s",str);
    len=strlen(str);   //len字符长度
    for(int i=0; i<(len+2)/3-1; i++)   //第一行到倒数第一行
    {
        printf("%c",str[i]);     //该行第一个字符
        for(int j=(len+2)/3; j<len-((len+2)/3-1)-1; j++)  //输出空格数
            printf(" ");
        printf("%c\n",str[len-1-i]);   //该行最后一个字符

    }
    for(int i=(len+2)/3-1; i<len-((len+2)/3-1); i++)  //最后一行
        printf("%c",str[i]);
    return 0;
}

运行结果:

发布了462 篇原创文章 · 获赞 55 · 访问量 32万+

猜你喜欢

转载自blog.csdn.net/LY_624/article/details/88735426