PAT-1031 Hello World for U

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82015488

1031 Hello World for U (20)(20 分)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~

  • n~2~ + n~3~ - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 根据条件计算n1,n2,n3即可。

#include<stdio.h>
#include<string.h>

int main(){
	char s[82];
	scanf("%s",s);
	int n=strlen(s);

	int max=0;
	for(int t2=3;t2<=n;t2++){
		int k=(n+2-t2)/2;
		if(k>max&&k<=t2)
			max=k;
	}
	int n2=n+2-2*max;
	for(int i=0;i<max;i++){
		for(int j=0;j<n2;j++){
			if(j==0)printf("%c",s[i]);
			else if(j==n2-1)printf("%c\n",s[n-i-1]);
			else if(i==max-1){
				printf("%c",s[max+j-1]);
			}else printf(" ");
		} 
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82015488