问题 B: Hello World for U

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34432960/article/details/87878332

题目描述

 

 

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

输入

 

 

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

 

输出

 

 

For each test case, print the input string in the shape of U as specified in the description.

 

样例输入

<span style="color:#333333">helloworld!</span>

样例输出

<span style="color:#333333">h   !
e   d
l   l
lowor
</span>

提示

 

 

 

这一题需要解决的问题是将一个字符串写成U字形。拿到这一题的第一映像是U字的写法(可没有茴香豆的“茴”写法多),先是写第一排第一个字符,然后写第二排第一个字符……然后是最后一排,然后是倒数第二排……但在C语言中如果我们要这样写U字形的字符串就需要在数组中操作了。如果是直接输出的话,那只能自上至下一行一行输出。首先是第一行,写出第一个字符和最后一个字符,第二行写出第二个字符和倒数第二个字符……最后是最后一行。需要注意的是除了最后一行输出所有字符,前面每一行只输出两个字符。中间还有空格来隔开每行的两个字符(具体有多少空格,待会计算)。

思路有了,看看具体的要求。字符串的长度是N,n1,n3代表两边每列字符的数目。n2代表最后一行的字符数。题目中给了一个算式:

n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

仔细研究这个算式,这里的k是不大于n2的,也就是说n1和n3是不大于n2且满足n1+n2+n3=N+2的最大值。那么自然有n1=n3=(N+2)/3,n2=N+2-(n1+n3)。也就是说设side为两边的字符数(包括最后一行的两端),则side=n1=n3=(N+2)/3。设mid为最后一行除去两端的两个字符后剩下的字符数,mid=N-side*2(总长度减去两边的字符数)。同时mid也是我们输出除最后一行外前面所有行需要空出的空格数。

最后如何在第一行输出第一个字符和最后一个字符呢?那自然是str[0]和str[len-1-i](len为字符串的长度,也就是N)。

于是问题完美解决,步骤如下:

1)计算字符串长度len;

2)计算两边的字符数side=(len+2)/3;

3)计算最后一行中间的字符数(前面每行中间的空格数);

4)输出每行相应的字符。

由于该题目不难,也没有什么需要特别注意的,我也就不写注意点了。具体细节详见参考代码。

 

#include<stdio.h>
#include<string.h>
int main()
{
	char a[100];
	scanf("%s",a);
	int N,side,mid;
	N = strlen(a);
	side=(N+2)/3;
	mid=N-2*side;
	//printf("len=%d side=%d mid=%d\n",N,side,mid);
	int i,j;
	for(i=0;i<side;i++)
	{
		for(j=0;j<mid+2;j++)
		{
			if(i<side-1)
			{
				if(j>0&&j<mid+1)printf(" ");
				else if(j==0)printf("%c",a[i]);
				else if (j==mid+1)printf("%c\n",a[N-1-i]); 
			}
			else{
				if(j<mid+1)printf("%c",a[side-1+j]);
				else{
					printf("%c\n",a[side-1+j]);
				}
			}
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34432960/article/details/87878332
今日推荐