HHUOJ 1759 Problem E

HHUOJ 1759 Problem E

题目描述

请写一个程序,判断给定表达式中的括号是否匹配,表达式中的合法括号为”(“, “)”, “[", "]“, “{“, ”}”,这三个括号可以按照任意的次序嵌套使用。

输入

有多个表达式,输入数据的第一行是表达式的数目,每个表达式占一行。

输出

对每个表达式,若其中的括号是匹配的,则输出”yes”,否则输出”no”。

样例输入

4
[(d+f)*{}]
[(2+3))
()}
[4(6]7)9

样例输出

yes
no
no
no

代码如下:

#include<iostream>
#include<stack>
#include<string>
#include<cstring>
using namespace std;
stack<int>s;
int main()
{
	int n;
	char a[10000];
	cin >> n;
	while (n--)
	{
		cin >> a;
		for (int i = 0; i < strlen(a); i++)
		{
			if (a[i] == '(' || a[i] == '[' || a[i] == '{') s.push(a[i]);
			else if (a[i] == ')' && !s.empty())
			{
				if (s.top()=='(')
				{
					s.pop();
				}
			}
			else if (a[i] == ']' && !s.empty())
			{
				if (s.top() == '[' )
				{
					s.pop();
				}
			}
			else if (a[i] == '}'&& !s.empty())
			{
				if (s.top() == '{')
				{
					s.pop();
				}
			}
			else if (s.empty())
			{
				s.push(a[i]);
			}
		}
		if (s.empty()) cout << "yes" << endl;
		else cout << "no" << endl;
		while (!s.empty()) 
		{
			s.pop();
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_43765333/article/details/88542545