1982 Problem B Problem E

问题 B: Problem E

时间限制: 1 Sec  内存限制: 32 MB
提交: 375  解决: 130
[提交][状态][讨论版][命题人:外部导入]

题目描述

请写一个程序,判断给定表达式中的括号是否匹配,表达式中的合法括号为”(“, “)”, “[", "]“, “{“, ”}”,这三个括号可以按照任意的次序嵌套使用。

输入

有多个表达式,输入数据的第一行是表达式的数目,每个表达式占一行。

输出

对每个表达式,若其中的括号是匹配的,则输出”yes”,否则输出”no”。

样例输入

4
[(d+f)*{}]
[(2+3))
()}
[4(6]7)9

样例输出

yes
no
no
no
#include<iostream>  
#include<string>
#include<stack>
using namespace std;

string str;

void match() {
	stack<char> a;
	for (int i = 0; i < str.length(); i++) {
		if (str[i] == '(' || str[i] == '[' || str[i] == '{')
			a.push(str[i]);
		else {
			if (a.empty()) {
				cout << "no" << endl;
				return;
			}
			char x;
			if (str[i] == ')') x = '(';
			else if (str[i] == ']') x = '[';
			else x = '{';
			if (x != a.top()) {
				cout << "no" << endl;
				return;
			}
			a.pop();
		}
	}
	if (a.empty()) cout << "yes" << endl;
	else cout << "no" << endl;
}

int main()
{
	int n;
	while (cin >> n) {
		while (n--) {
			cin >> str;
			for (string::iterator it = str.begin(); it != str.end(); it++) {
				if (*it != '('&&*it != ')'&&*it != '['&&*it != ']'&&*it != '{'&&*it != '}') {
					str.erase(it);
					it--;//注意刪除后it位置变化
				}
			}
			match();
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36502291/article/details/84554314