PTA天梯赛L2-005 集合相似度【set】

给定两个整数集合,它们的相似度定义为:N​c​​/N​t​​×100%。其中N​c​​是两个集合都有的不相等整数的个数,N​t​​是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N(≤50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(≤10​4​​),是集合中元素的个数;然后跟M个[0,10​9​​]区间内的整数。

之后一行给出一个正整数K(≤2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例:

50.00%
33.33%

思路:刚开始实在是没有想明白题意是让干嘛的,后来才知道是交集/并集 ,根据set不会有重复的键值 的特点,可以方便的写这道题。

#include<set>
#include<map>
#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 55;
set<int> s[55];

int main()
{
    int n;
    cin >> n;
    for(int i = 1; i <= n; ++i)
    {
        int m, tmp;
        cin >> m;
        for(int j = 0; j < m; ++j)
        {
            cin >> tmp;
            s[i].insert(tmp);
        }


    }
    int k;
        cin >> k;
        while(k--)
        {
            int x, y;
            cin >> x >> y;
            int lenx = s[x].size(), leny = s[y].size();
            set<int> ::iterator it = s[x].begin();
            int cnt = 0;
            for(;it != s[x].end(); ++it)
            {
                if(s[y].count(*it))
                    cnt++;
            }
            double ans = cnt * 1.0 / (lenx + leny - cnt) * 100;
            printf("%0.2lf%%\n", ans);
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41785863/article/details/88880217