HDU-1068 Girls and Boys

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Output

5
2

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题意:有n个人,一些人认识另外一些人,选取一个集合,使得集合里的每个人都互相不认识,求该集合中人的最大个数。
题解:这题就是求最大独立集,但是这并不是两个集合,而是一个集合,所以求出最大匹配后需要/2,然后代公式:最大独立集=N-最大匹配。

代码;

#include <stdio.h>
#include <string.h>
int e[1010][1010];
int match[1010],book[1010];
int n;

int dfs(int v)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(book[i]==0&&e[v][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=v;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,m,u,v,ans;
	while(scanf("%d",&n)!=EOF)
	{
		memset(e,0,sizeof(e));
		memset(book,0,sizeof(book));
		memset(match,0,sizeof(match));
		for(i=1;i<=n;i++)
		{
			scanf("%d: (%d)",&u,&v);
			for(j=1;j<=v;j++)
			{
				scanf("%d",&m);
				e[u][m]=1;
			}
		}
		ans=0;
		for(i=0;i<n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				ans++;
		}
		printf("%d\n",n-(ans/2));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81538491