HDU1061

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
代码:
import java.util.*;
public class Main {
	static int mypow(int a,int b)
	{
		int sum = 1;
		while(b!=0)
		{
			if(b % 2 ==1) sum=sum * a %10;
			a = a * a % 10;
			b = b>>1;
		}
		return sum;
	}
	public static void main(String []args){
		int [] num = new int [25];
		for(int i = 1;i<=20;i++)
		{
			num[i] = mypow(i,i);
		}
		int n,k;
		Scanner sc = new Scanner(System.in);
		n = sc.nextInt();
		for(int i = 1;i <= n;i++)
		{
			k = sc.nextInt();
			System.out.println(num[k % 20==0? 20:k%20]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/81148688
今日推荐