hdu1058

这是杭电oj dp类题目的第二题

Humble Numbers

 

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

Sample Input

 

1 2 3 4 11 12 13 21 22 23 100 1000 5842 0

 

Sample Output

 

The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

分析:

没什么可分析的,就是一道简单dp只要把思路理清楚,接下来的就都不是问题了

题意:首先我们建一个线性表将所有符合要求的数按从小到大的顺序存入表内;

只不过这个输比较特殊,我们需要注意。

本题的主要点就是如何找到所有符合题意的数,并且按从大到小排列,题目要求的数是因子只有2,3,5,7.

这就是dp的内容,其实就是把之前的数乘2,3 ,5,7,得到最小的数存入线性表内

上代码

#include <bits/stdc++.h>
#define smaller(a,b) (a<b?a:b)
#define smallest(a,b,c,d) smaller(smaller(a,b),smaller(c,d)) 
typedef long long ll;
using namespace std;
ll dp[6000]; 
int main()
{
	int nu1,nu2,nu3,nu4;
	nu1=nu2=nu3=nu4=1;
	memset(dp,0,sizeof(dp));
	dp[1]=1;
	for(int i=2;i<=5842;i++)从第二个开始因为第一个是1
	{
		dp[i]=smallest(dp[nu1]*2,dp[nu2]*3,dp[nu3]*5,dp[nu4]*7);找到最小的存进去
        记录乘到了第几位,到哪个数
		if(dp[i]==dp[nu1]*2)
			nu1++;
		if(dp[i]==dp[nu2]*3)
			nu2++;
		if(dp[i]==dp[nu3]*5)
			nu3++;
		if(dp[i]==dp[nu4]*7)
			nu4++;
	}
	int n;
	while(cin>>n&&n)
	{
标准输出
		if(n%100==11  ||  n%100==12 || n%100==13)      
		 	printf("The %dth humble number is %lld.\n",n,dp[n]);
	  	else if(n%10==1)     
			printf("The %dst humble number is %lld.\n",n,dp[n]); 
		else if(n%10==2)       
			printf("The %dnd humble number is %lld.\n",n,dp[n]);  
		else if(n%10==3)       
			printf("The %drd humble number is %lld.\n",n,dp[n]);  
		else       
			printf("The %dth humble number is %lld.\n",n,dp[n]);
	}
	return 0;
}
 
 
 
 
 

猜你喜欢

转载自blog.csdn.net/weixin_42105529/article/details/82931986