【hackerrank】-Day 5: Loops

30-loops
Objective
In this challenge, we’re going to use loops to help us do some simple math. Check out the Tutorial tab to learn more.

Task
Given an integer, , print its first multiples. Each multiple (where ) should be printed on a new line in the form: n x i = result.

Input Format

A single integer, .

Constraints

Output Format

Print lines of output; each line (where ) contains the of in the form:
n x i = result.

Sample Input

2
Sample Output

2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20


#!/bin/python3

import math
import os
import random
import re
import sys



if __name__ == '__main__':
    n = int(input())
    if n < 2 or n > 20:
        print('n < 2 or n > 20')
    for i in range(0, 10):
        i = i + 1
        print("%d x %d = %d" % (n, i, (n*i)))

Congratulations!

You have passed the sample test cases. Click the submit button to run your code against all the test cases.

Testcase 0
Input (stdin)
2
Your Output (stdout)
2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20
Expected Output
2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20
AuthorAvmnuSng
DifficultyEasy
Max Score30
Submitted By201558
NEED HELP?
View tutorial
View discussions
View editorial
View top submissions
RATE THIS CHALLENGE

MORE DETAILS
Download problem statement
Download sample test cases
Suggest Edits

猜你喜欢

转载自blog.csdn.net/langhailove_2008/article/details/81176721