hdu-2084-数塔-dp-java

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 53741    Accepted Submission(s): 31567


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
 
  
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
 
  
30
 

Source
2006/1/15 ACM程序设计期末考试


解题思路:
                      额好奇的我写了个递归搜索果然超时(手动笑哭)然后老老实实的用dp写 emmm 从底自上dp 没啥可说的

import java.util.Scanner;

public class Main {

    private static int n;
    private static int[][] arr;

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner scanner = new Scanner(System.in);
        int t = scanner.nextInt();
        for (int i = 0; i < t; i++) {
            n = scanner.nextInt();
            arr = new int [n+1][n+1];
            int [][] dp = new int [n+1][n+1];
            for (int j = 1; j < arr.length-1; j++) {
                for (int j2 = 1; j2 <= j; j2++) {
                    arr[j][j2] = scanner.nextInt();
                }
            }
            for (int j = 1; j < dp.length; j++) {
                arr[n][j] = scanner.nextInt();
                dp[n][j] = arr[n][j];
            }
            for (int j = n-1; j >= 1; j--) {
                for (int j2 = 1; j2 <= j; j2++) {
                    dp[j][j2] = Math.max(dp[j+1][j2], dp[j+1][j2+1]) + arr[j][j2];
                }
            }
            System.out.println(dp[1][1]);
        }
    }

}


猜你喜欢

转载自blog.csdn.net/lijinyuliangyan/article/details/80060787