Freckles(九度 OJ 1144)-并差集

题目描述:
      In an episode of the Dick Van Dyke show, little Richie connects the freckles on
his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out
to be a scar, so his Ripley’s engagement falls through.Consider Dick’s back to be a
plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect
the dots so as to minimize the amount of ink used. Richie connects the dots by
drawing straight lines between pairs, possibly lifting the pen between lines. When
Richie is done there must be a sequence of connected lines from any freckle to any
other freckle.
输入:
      The first line contains 0 < n <= 100, the number of freckles on Dick’s back. For
each freckle, a line follows; each following line contains two real numbers indicating
the (x,y) coordinates of the freckle.
输出:
      Your program prints a single real number to two decimal places: the minimum
total length of ink lines that can connect all the freckles.
样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
来源:

2009 年北京大学计算机研究生机试真题

#include<stdio.h>
#include<algorithm>
#include<math.h> 
#define N 101
#define M 5000
using namespace std;
struct Point{//点集 
	double x;
	double y;
}point[N];

struct Edge{//边集 
	int p1;
	int p2;
	double v;
}edge[M];
int cmp(Edge a,Edge b){
	return a.v<b.v;
}
int Tree[N];//连通分量 
int findRoot(int x){
	if(Tree[x]==-1) return x;
	else{
		int tmp=findRoot(Tree[x]);
		Tree[x]=tmp;
		return tmp;
	}
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int m=0;
		for(int i=1;i<=n;i++) Tree[i]=-1;
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&point[i].x,&point[i].y);//double用%lf输入,%f输入出错 
		}
		for(int i=1;i<=n-1;i++){
			for(int j=i+1;j<=n;j++){
				double len;
				len=pow((point[i].x-point[j].x),2)+pow((point[i].y-point[j].y),2);
				len=sqrt(len);
				edge[m].p1=i;
				edge[m].p2=j;
				edge[m].v=len;
				m++;
			}
		}
		sort(edge,edge+m,cmp);
		double ans=0;
		for(int i=0;i<m;i++){
			int a=findRoot(edge[i].p1);
			int b=findRoot(edge[i].p2);
			if(a!=b){
				Tree[a]=b;
				ans+=edge[i].v;
			}
		}
		printf("%.2lf\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/xiaowennuan163/article/details/88372857