【ZOJ2855】Google Map(模拟)

题目链接

Google Map


Time Limit: 2 Seconds      Memory Limit: 65536 KB


GoogleMap is a useful tool and most of you should be familiar with it. As the best hacker in the world, Jack is planning to retrieve all the data on the GoogleMap server. But he soon gives up because the total amount of data exceeds 1000T bytes! But he has learnt the way in which Google stores their data on the server, and he turns to download only the parts that he's interested in. Here is the representation of the data that Jack has found:

First of all, you should know the basic background knowledge of GIS (Geography Information System). In GoogleMap, the whole world is represented in a whole flat image transformed from the surface of the earth by Mercator projection. The Mercator projection is a map projection which is widely used for navigation. The following equations place the x-axis of the projection on the equator (from West to East) and the y-axis at longitude 0 (from South to North)

  • x = longitude * pi / 180;
  • y = ln(tan(pi / 4 + (latitude * pi / 180) / 2))

Here, the latitude is between [-85, 85] (negative for South) and the longitude is between [-180, 180] (negative for West) The left of the map image is W180 and the right is E180. The top of the map image is N85 and the bottom is S85. The maps have different levels. In the first level, the whole image consists of only one tile with tag name "t". For each tile in one level, it will be clipped into 4 equally sized parts and magnified by 2 in the next level.

And the new tag name for the tiles in the next level will be the tag of their parent tile followed by the identifier of the clip area in the parent tile. (that is, q for left-top, r for right-top, t for left-bottom, s for right-bottom) For example:

扫描二维码关注公众号,回复: 2901637 查看本文章

So there will be 4L tiles in level L (Assume the first level is labeled as level 0). More interestingly, the filename of the tile on the server is just the tag name. Although Jack is very genius, he doesn't know any programming language, so he turns to you for writing a tool to generate the tags for him.

Input

The input contains multiple test cases!

In each case, there will be three numbers. The first two are the coordinates that indicate the longitude and latitude of the interested location, and the third is the level number required by Jack.

The longitude is between [-180, 180] (negative for West) and the latitude is between [-85, 85] (negative for South)

Output

Output the tag for the tile in the specified level that contains the location in a single line.

You can assume that the location will not be at the boundary of any tiles.

Sample Input

80 33 2
-80 -33 4
72.12 46.68 10

Sample Output

trt
ttrqt
trtrstqsrqs

Notes

You can use the 'log(double)' function to calculate the natural logarithm, and 'tan(double)' to calculate the tangent value. Both of these functions are included in the header '<math.h>' for C or '<cmath>' for C++.

【题意】

根据一个实际位置的经纬度计算它属于图中的那一块然后输出位置。

【解题思路】

555555其实是道水题啦,看懂题目意思就好了,以后千万不能因为题目长就觉得难不看,有时候可能是相反的!!

实际的经纬度就根据上述公式转换成图上的位置就好啦,然后不断二分判断其在图中四个位置中的哪个位置。

代码:

#include<bits/stdc++.h>
using namespace std;
using namespace std;
const double PI=acos(-1);
double n,s,w,e;
int main()
{
    double t1,t2;
    int m;
    while(~scanf("%lf%lf%d",&t1,&t2,&m))
    {
        n=log(tan(PI/4.0+(85.0*PI/180.0)/2.0));
        s=log(tan(PI/4.0+(-85.0*PI/180.0)/2.0));
        w=-PI;
        e=PI;
        double x=(t1*PI)/180.0;
        double y=log(tan(PI/4.0+(t2*PI/180.0)/2.0));
        printf("t");
        for(int i=0;i<m;i++)
        {
            if(x>(w+e)/2.0)//右
            {
                w=(w+e)/2.0;
                if(y>(n+s)/2)//上
                {
                    s=(s+n)/2.0;
                    printf("r");
                }
                else//下
                {
                    n=(n+s)/2.0;
                    printf("s");
                }
            }
            else//左
            {
                e=(w+e)/2.0;
                if(y>(n+s)/2)//上
                {
                    s=(s+n)/2.0;
                    printf("q");
                }
                else//下
                {
                    n=(n+s)/2.0;
                    printf("t");
                }
            }
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/81875830