ZOJ-3948 Marjar Cola(模拟)

版权声明:本人大三在读,有错误烦请指正,共同进步- ( ゜- ゜)つロ 乾杯~点赞请按右上角,转载请标明出处: https://blog.csdn.net/hzyhfxt/article/details/83095764

Description

Marjar Cola is on sale now! In order to attract more customers, Edward, the boss of Marjar Company, decides to launch a promotion: If a customer returns x empty cola bottles or y cola bottle caps to the company, he can get a full bottle of Marjar Cola for free!

Now, Alice has a empty cola bottles and b cola bottle caps, and she wants to drink as many bottles of cola as possible. Do you know how many full bottles of Marjar Cola she can drink?

Note that a bottle of cola consists of one cola bottle and one bottle cap.

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases. For each test case:

The first and only line contains four integers x, y, a, b (1 ≤ x, y, a, b ≤ 100). Their meanings are described above.

Output

For each test case, print one line containing one integer, indicating the number of bottles of cola Alice can drink. If Alice can drink an infinite number of bottles of cola, print "INF" (without the quotes) instead.

Sample Input

2
1 3 1 1
4 3 6 4

Sample Output

INF
4

Hint

For the second test case, Alice has 6 empty bottles and 4 bottle caps in hand. She can return 4 bottles and 3 caps to the company to get 2 full bottles of cola. Then she will have 4 empty bottles and 3 caps in hand. She can return them to the company again and get another 2 full bottles of cola. This time she has 2 bottles and 2 caps in hand, but they are not enough to make the exchange. So the answer is 4.

直接模拟就行啦 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define go(i,a,b) for(int i=a;i<=b;i++)
#define og(i,a,b) for(int i=a;i>=b;i--)
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e6 + 5;
typedef long long ll;
using namespace std;
int x, y, a, b;
int solve()
{
    int cnt = 0;
    if(x == 1 || y == 1)    
        return -1;
    if(x == 2 && y == 2 && (a>=2 || b>=2))
        return -1;
    while(a >= x || b >= y)
    {
        if(a >= x)  
            a-=x;
        else if(b >= y) 
            b -= y;
        else
            continue;
        a++,b++,cnt++;
    }
    return cnt;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d %d",&x, &y, &a,&b);
        int ans = solve();
        if(ans == -1)   
            printf("INF\n");
        else 
            printf("%d\n", ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/83095764