模拟-Puzzle

A children’s puzzle that was popular 30 years ago consisted of a 5x5 frame which contained 24 small squares of equal size. A unique letter of the alphabet was printed on each small square. Since there were only 24 squares within the frame, the frame also contained an empty position which was the same size as a small square. A square could be moved into that empty position if it were immediately to the right, to the left, above, or below the empty position. The object of the puzzle was to slide squares into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after the following sequence of 6 moves:

  1. The square above the empty position moves.

  2. The square to the right of the empty position moves.

  3. The square to the right of the empty position moves.

  4. The square below the empty position moves.

  5. The square below the empty position moves.

  6. The square to the left of the empty position moves.

Write a program to display resulting frames given their initial configurations and sequences of moves.

Input
Input for your program consists of several puzzles. Each is described by its initial configuration and the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting configuration. Subsequent lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The other lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square moves into the empty position. A denotes that the square above the empty position moves; B denotes that the square below the empty position moves; L denotes that the square to the left of the empty position moves; R denotes that the square to the right of the empty position moves. It is possible that there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.

Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final configuration should be displayed.
Format each line for a final configuration so that there is a single blank character between two adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior position, then it will appear as a sequence of 3 blanks - one to separate it from the square to the left, one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above.

Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z

Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.

题目大意:给出一个五行五列的字符矩阵,矩阵中有一个空格,接下来会有一行或多行操作,并以数字0结尾,A、B、L、R分别表示空格移动到上下左右,如果遇到非法操作,即越界,则直接输出This puzzle has no final configuration.即可。
有多组测试,直到输入字符Z结束

思路:emmmm典型的模拟题,题目太长了,废了好变天的劲才弄懂,废话不多说,上代码

#include<iostream>
#include<stdio.h>

using namespace std;

char l[10][10],m[10005];
int n=0,flag,x,y,ex,ey,ind;//n用来记录测试的数量,flag用来判断是否越界
//x,y用来记录空格位置,ex,ey用来记录需要操作的位置
int main()
{
    while(gets(l[0]))
    {
        flag=0;//初始化为0
        
        if(l[0][0]=='Z')//结束条件
            break;
            
        for(int i=1;i<5;i++)//接收剩下的四行
            gets(l[i]);
            
        for(int i=0;i<5;i++)//找出空格的位置
            for(int j=0;j<5;j++)
                if(l[i][j]==' ')
                    {
                        x=i;
                        y=j;
                        break;
                    }
        ind=0;
        while(cin>>m[ind])//读入操作
        {
            if(m[ind]=='0')
                break;
            else
                ind++;
        }
        
        m[ind]=0;
        getchar();
        ex=x,ey=y;//这行一定要写
        for(int i=0;m[i];i++)
        {
            if(m[i]=='A')
                ex-=1;
            else if(m[i]=='B')
                ex+=1;
            else if(m[i]=='L')
                ey-=1;
            else if(m[i]=='R')
                ey+=1;
            if(ex<0||ex>4||ey<0||ey>4)//如果越界,标记变为1,跳出即可
            {
                flag=1;
                break;
            }
            else//否则进行交换即可
            {
                l[x][y]=l[ex][ey];
                l[ex][ey]=' ';
                x=ex;
                y=ey;
            }
        }
        if(n++)//输出一个空行
            cout<<endl;
        printf("Puzzle #%d:\n",n);//打印测试数目
        if(flag)//如果越界
            printf("This puzzle has no final configuration.\n");
        else
        {
            for(int i=0;i<5;i++)
            {
                for(int j=0;j<5;j++)
                {
                    if(j)
                        cout<<" ";//输出空格
                    cout<<l[i][j];
                }
                cout<<endl;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42891420/article/details/87970881