Multiplication Puzzle

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650


题意:从一堆放好的卡片中取一个卡片(不能取开头和结尾的卡片),每次取出一个卡片的时候,就计算一个值:该卡片上的数字和他左右卡片的数字的乘积。重复这个操作直到只剩下两个卡片,将所有得到的值加起来。求这个值的最小值是多少。

题意:dp[i][j]表示从第i张到第j张的最小的值,状态转移方程dp[i][j] = min(dp[i][j],dp[i][k] + dp[k][j] + a[i] * a[k] * a[j]),k表示最后一个取走的卡牌,i<k<j。

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;

const int maxn = 105;
const int inf = 0x3f3f3f3f;

int main()
{
    int n;
    int a[maxn];
    int dp[maxn][maxn];
    while(scanf("%d",&n) != EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int l = 2;l <= n - 1;l++)
        {
            for(int i = 1;i + l <= n;i++)
            {
                int j = i + l;
                dp[i][j] = inf;
                for(int k = i + 1;k <= j - 1;k++)
                {
                    dp[i][j] = min(dp[i][j],dp[i][k] + dp[k][j] + a[i] * a[j] * a[k]);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/eric_chen_song_lin/article/details/80113782