Wormholes POJ - 3259 最短路径(Bellman-Ford算法)

  • Wormholes

题目链接:http://poj.org/problem?id=3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

扫描二维码关注公众号,回复: 5374504 查看本文章

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:虫洞是很奇特的,因为它是一个**单向**通道,可让你进入虫洞的前达到目的地!他的N(1≤N≤500)个农场被编号为1..N,之间有M(1≤M≤2500)条路径,W(1≤W≤200)个虫洞。FJ作为一个狂热的时间旅行的爱好者,他要做到以下几点:开始在一个区域,通过一些路径和虫洞旅行,他要回到最开时出发的那个区域出发前的时间。也许他就能遇到自己了:)。为了帮助FJ找出这是否是可以或不可以,他会为你提供F个农场的完整的图(1≤F≤5)。所有的路径所花时间都不大于10000秒,所有的虫洞都回到不大于10000秒之前。

思路:Bellman-Ford算法模板题,判断是否存在负权回路,注意回溯的时间输入的是正的,要转化为负数。

AC代码:

204ms

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
#define ll long long
const int INF = 0x3f3f3f3f;
const int MAXN = 1000000 + 5;
using namespace std;
int n, m, w;
double y;
double dist[MAXN];
//double map[110][110];
struct edge{
	int st,end;
	int cost;
}e[3000];
//int visit[110];
//void dijkstra(int x);
bool Bellman_Ford(int cnt);
int main()
{
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d%d", &n, &m, &w);
		int k = 0;
		for (int i = 1; i <= m; ++i) {
			int a, b, c;
			k++;
			scanf("%d%d%d", &a, &b, &c);
			e[k].st = a;
			e[k].end = b;
			e[k].cost = c;
			k++;
			e[k].st = b;
			e[k].end = a;
			e[k].cost = c;
		}
		for (int i = 1; i <= w; ++i) {
			k++;
			scanf("%d%d%d", &e[k].st, &e[k].end, &e[k].cost);
			e[k].cost = -e[k].cost;
		}
		if (!Bellman_Ford(k))
			printf("YES\n");
		else
			printf("NO\n");
	}
}

bool Bellman_Ford(int cnt) {
	for (int i = 1; i <= n; ++i) {
		dist[i] = INF;
	}
	dist[1] = 0;
	for (int j = 1; j < n; ++j) {
		for (int i = 1; i <= cnt; ++i) {
			int x = e[i].st, y = e[i].end;
			if (dist[y] > dist[x] + e[i].cost) {
				dist[y] = dist[x] + e[i].cost;
			}
		}
	}
	for (int i = 1; i <= cnt; ++i) {
		int x = e[i].st, y = e[i].end;
		if (dist[y] > dist[x] + e[i].cost)
			return false;
	}
	return true;
}

猜你喜欢

转载自blog.csdn.net/weixin_43821265/article/details/86715886