有向图欧拉通路

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

就是给你一些单词 问你可不可以首尾连接    欧拉通路要联通 且入度=出度 或 有两个特殊点 一个入-出=1 一个反之

建立并查集 看图是否联通 然后再接着判断

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=26+6;
int fa[maxn];
int in[maxn],out[maxn];
int m;//单词数
int findset(int u)
{
    if(fa[u]==-1)
        return u;
    return fa[u]=findset(fa[u]);
}
//入度=出度或有两个特殊节点,一个入度-出=1,一个反之 图联通
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        memset(fa,-1,sizeof(fa));
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            char str[1200];
            scanf("%s",str);
            int len=strlen(str);
            int u=str[0]-'a', v=str[len-1]-'a';
            in[u]++;
            out[v]++;
            u=findset(u), v=findset(v);
            if(u!=v)
                fa[u]=v;
        }
        int cnt=0;
        for(int i=0; i<26; i++)
            if( (in[i]||out[i]) && findset(i)==i )
                cnt++;//注意这里是为了避免有些字母没有出现
        if(cnt>1)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int c1=0, c2=0, c3=0;//分别表示入度!=出度时的三种情况
        for(int i=0; i<26; i++)
        {
            if(in[i]==out[i])
                continue;
            else if(in[i]-out[i]==1)
                c1++;
            else if(out[i]-in[i]==1)
                c2++;
            else
                c3++;
        }
        if( ( (c1==c2&&c1==1)||(c1==c2&&c1==0) )&&c3==0 )
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/87901151