E - Rabbit hunt

A good hunter kills two rabbits with one shot. Of course, it can be easily done since for any two points we can always draw a line containing the both. But killing three or more rabbits in one shot is much more difficult task. To be the best hunter in the world one should be able to kill the maximal possible number of rabbits. Assume that rabbit is a point on the plane with integer x and y coordinates. Having a set of rabbits you are to find the largest number K of rabbits that can be killed with single shot, i.e. maximum number of points lying exactly on the same line. No two rabbits sit at one point.

Input

An input contains an integer N (2<=N<=200) specifying the number of rabbits. Each of the next N lines in the input contains the x coordinate and the y coordinate (in this order) separated by a space (-1000<=x,y<=1000).

Output

The output contains the maximal number K of rabbits situated in one line.

Sample Input

6
7 122
8 139
9 156
10 173
11 190
-100 1

Sample Output

5
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int x[202];
int y[202];
int res;
int main(){
	int n;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>x[i]>>y[i];
	}
	for(int i=1;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			int ress=2;
			for(int k=j+1;k<=n;k++){
				if((x[i]-x[k])*(y[j]-y[k])==(x[j]-x[k])*(y[i]-y[k])){
					ress++;
				}
			}
			
			res=max(res,ress);
			if(res>=(n+1)/2){
				cout<<res<<endl;
				return 0;
			}
		}
	}
	cout<<res<<endl;
	return 0;
} 

数据小,可以直接暴力。

同时i,j,k.的下标保证能取到最大值就行了,不一定要从1开始

还有只要大于等于一半就可以不再继续了。

所以适当简化,虽然很简单。

猜你喜欢

转载自blog.csdn.net/qq_42865713/article/details/87266591
今日推荐