uva 1596 Bug Hunt

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tengfei461807914/article/details/81613037

原题:
In this problem, we consider a simple programming language that has only declarations of one dimensional integer arrays and assignment statements. The problem is to find a bug in the given program.

Characters used in a program are alphabetical letters, decimal digits, =, [, ] and new line characters. No other characters appear in a program. A declaration declares an array and specifies its length. Valid indices of an array of length n are
integers between 0 and n − 1, inclusive. Note that the array names are case sensitive, i.e. array a and array A are different arrays. The initial value of each element in the declared array is undefined. For example, array a of length 10 and array b of length 5 are declared respectively as follows.

a[10]
b[5]

An expression evaluates to a non-negative integer. A ⟨number⟩ is interpreted as a decimal integer.
An ⟨array name⟩ [⟨expression⟩] evaluates to the value of the ⟨expression⟩-th element of the array.
An assignment assigns the value denoted by the right hand side to the array element specified by the
left hand side.
Examples of assignments are as follows.

a[0]=3
a[1]=0
a[2]=a[a[1]]
a[a[0]]=a[1]

A program is executed from the first line, line by line. You can assume that an array is declared
once and only
once before any of its element is assigned or referred to.
Given a program, you are requested to find the following bugs.
• An index of an array is invalid.
• An array element that has not been assigned before is referred to in an assignment as an index
of array or as the value to be assigned.
You can assume that other bugs, such as syntax errors, do not appear. You can also assume that
integers represented by ⟨number⟩s are between 0 and 2 31 − 1 (= 2147483647), inclusive.

Input
The input consists of multiple datasets followed by a line which contains only a single ‘.’ (period).
Each dataset consists of a program also followed by a line which contains only a single ‘.’ (period).
A program does not exceed 1000 lines. Any line does not exceed 80 characters excluding a new line
character.
Output
For each program in the input, you should answer the line number of the assignment in which the first
bug appears. The line numbers start with 1 for each program. If the program does not have a bug,
you should answer zero. The output should not contain extra characters such as spaces.

Sample Input
a[3]
a[0]=a[1]
.
x[1]
x[0]=x[0]
.
a[0]
a[0]=1
.
b[2]
b[0]=2
b[1]=b[b[0]]
b[0]=b[1]
.
g[2]
G[10]
g[0]=0
g[1]=G[0]
.
a[2147483647]
a[0]=1
B[2]
B[a[0]]=2
a[B[a[0]]]=3
a[2147483646]=a[2]
.
.
Sample Output
2
2
2
3
4
0

中文:
(来自紫书)
输入并模拟执行一段程序,输出第一个bug所在的行。每行程序有两种可能:
数组定义,格式为arr[size]。例如a[10]或者b[5],可用下标分别是0~9和0~4。定义之
后所有元素均为未初始化状态。
赋值语句,格式为arr[index]=value。例如a[0]=3或者a[a[0]]=a[1]。
赋值语句可能会出现两种bug:下标index越界;使用未初始化的变量(index和value都可
能出现这种情况)。
程序不超过1000行,每行不超过80个字符且所有常数均为小于2 31 的非负整数。

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

struct node
{
    int siz;//数组大小
    map<int, int> mi;//数组中的每个元素
};

string s;




map<string, node> mark;//记录每个数组的大小

string get_s(string &x, int st, int e)
{
    string tmp = "";
    for (int i = st; i <= e; i++)
        tmp += x[i];
    return tmp;
}

int Define(string x)
{
    int i = 0, j = x.size() - 1;
    while (s[i] != '[')
        i++;
    string name, len;
    long l;

    name = x.substr(0, i);
    len = x.substr(i + 1, x.size() - i - 2);

    if (len.size()>10)
        return false;
    l = stoi(len);
    if (l>INT_MAX)
        return -1;
    mark[name].siz = (int)l;
    return 1;
}


int dfs(string &x1, int st, int e, int &flag)//等号右侧
{
    if (flag == 0)
        return -1;
    string tmp = get_s(x1, st, e);
    if (tmp.find('[') == string::npos)//如果中间的数全是数字返回
    {
        long l = stol(tmp);
        if (l >= INT_MAX)
            return -1;
        return (int)l;
    }
    int i = st, j = e - 1;
    while (x1[i] != '[')
        i++;
    i++;
    int val = dfs(x1, i, j, flag);

    if (val == -1)
    {
        flag = 0;
        return -1;
    }
    string name = get_s(x1, st, i - 2);
    if (mark[name].siz <= val || mark[name].mi.find(val) == mark[name].mi.end())//下标越界或者name[val]未赋值(注意最外层的值可以是未赋值)
    {
        flag = 0;
        return -1;
    }

    return mark[name].mi[val];

}

int dfs(string &x1, int st, int e, int &flag, string& na,int &va)//等号左侧
{
    if (flag == 0)
        return -1;
    string tmp = get_s(x1, st, e);
    if (tmp.find('[') == string::npos)//如果中间的数全是数字返回
    {
        long l = stol(tmp);
        if (l >= INT_MAX)
            return -1;
        return (int)l;
    }
    int i = st, j = e - 1;
    while (x1[i] != '[')
        i++;
    i++;
    int val = dfs(x1, i, j, flag, na,va);

    if (val == -1)
    {
        flag = 0;
        return -1;
    }
    string name = get_s(x1, st, i - 2);
    if (mark[name].siz <= val ||(mark[name].mi.find(val) == mark[name].mi.end()&&st!=0))//下标越界或者name[val]未赋值(注意最外层的值可以是未赋值)
    {
        flag = 0;
        return -1;
    }
    if (st == 0)
    {
        na = name;
        va = val;
    }
    return mark[name].mi[val];

}

int main()
{
    ios::sync_with_stdio(false);
    while (true)
    {
        int ind = 1, ans = 0, flag = 1;
        bool f = 0;
        mark.clear();
        while (cin >> s)
        {
            if (s == ".")
                break;
            f = 1;
            if (flag == 0)
                continue;
            auto e = s.find('=');
            if (e == string::npos)
            {
                ans = Define(s);
                if (ans == -1)
                {
                    ans = ind;
                    flag = 0;
                    continue;
                }
            }
            else
            {
                string pre = s.substr(0, e), pos = s.substr(e + 1, s.size() - e+1);
                int flag1=1, flag2=1,rhs,lhs;
                string name;
                rhs=dfs(pos, 0, pos.size() - 1, flag2);//右值
                if (flag2 == 0)
                {
                    ans = ind;
                    flag = 0;
                    continue;
                }
                dfs(pre, 0, pre.size() - 1, flag1,name, lhs);//左值
                if (flag1 == 0)
                {
                    ans = ind;
                    flag = 0;
                    continue;
                }
                mark[name].mi[lhs] = rhs;
            }


            ind++;

        }
        if (!f)
            break;
        if (flag)
            cout << 0 << endl;
        else
            cout << ans << endl;


    }
    return 0;
}

解答:

紫书上面的练习题,用来锻炼锻炼代码能力还是挺不错的。

思路很简单,模拟即可。

声明语句使用Define函数判断是否合法

赋值语句使用递归的方式来分别解析等号左侧(左值),等号右侧(右值)是否合法。

猜你喜欢

转载自blog.csdn.net/tengfei461807914/article/details/81613037
今日推荐