POJ -1066—Treasure Hunt

Treasure Hunt

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8367   Accepted: 3463

Description

Archeologists from the Antiquities and Curios Museum (ACM) have flown to Egypt to examine the great pyramid of Key-Ops. Using state-of-the-art technology they are able to determine that the lower floor of the pyramid is constructed from a series of straightline walls, which intersect to form numerous enclosed chambers. Currently, no doors exist to allow access to any chamber. This state-of-the-art technology has also pinpointed the location of the treasure room. What these dedicated (and greedy) archeologists want to do is blast doors through the walls to get to the treasure room. However, to minimize the damage to the artwork in the intervening chambers (and stay under their government grant for dynamite) they want to blast through the minimum number of doors. For structural integrity purposes, doors should only be blasted at the midpoint of the wall of the room being entered. You are to write a program which determines this minimum number of doors. 
An example is shown below: 

Input

The input will consist of one case. The first line will be an integer n (0 <= n <= 30) specifying number of interior walls, followed by n lines containing integer endpoints of each wall x1 y1 x2 y2 . The 4 enclosing walls of the pyramid have fixed endpoints at (0,0); (0,100); (100,100) and (100,0) and are not included in the list of walls. The interior walls always span from one exterior wall to another exterior wall and are arranged such that no more than two walls intersect at any point. You may assume that no two given walls coincide. After the listing of the interior walls there will be one final line containing the floating point coordinates of the treasure in the treasure room (guaranteed not to lie on a wall).

Output

Print a single line listing the minimum number of doors which need to be created, in the format shown below.

Sample Input

7 
20 0 37 100 
40 0 76 100 
85 0 0 75 
100 90 0 90 
0 71 100 61 
0 14 100 38 
100 47 47 100 
54.5 55.4 

Sample Output

Number of doors = 2 

Source

扫描二维码关注公众号,回复: 5020502 查看本文章

East Central North America 1999

题目大意:大意:给你一个房间,房间内有很多墙,再给你个宝藏的坐标,你将使用炸药从外面砸墙而入
问:你炸墙进去通过的最少的墙的1数目是多少

思路:枚举每个端点(加上四个角)与宝藏形成的线段会和那几条线段相交,取交点最少的。

PS:题上说的是各个墙的中点,但是要枚举端点,不要枚举线段的中点,例如这种情况:

判断中点是肯定不对的,我只需要1次就好,为啥还要炸两次??

所以还是要枚举端点

代码:

/*
大意:给你一个房间,房间内有很多墙,再给你个宝藏的坐标,你将使用炸药从外面砸墙而入
问:你炸墙进去通过的最少的墙的1数目是多少
思路:初始值为1,枚举每个端点到宝藏位置会与多少条线段相交,取最小值

*/
#include<map>
#include<stack>
#include<queue>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define ul unsigned long long
#define bug printf("mmp\n");
#define inf 0x3f3f3f3f
#define esp 1e-4
#define mm(a,b) memset(a,b,sizeof(a))
#define T()int test,q=1,tt;scanf("%d",&test),tt=test;while(test--)
const int N=1e2+10;
const int maxn=1e6+100;
const int mod=1000000007;
struct point
{
    double x,y;
} p[N];
struct line
{
    point st,ed;
    double k,b;
} l[N];
int sign(double x)
{
    if(fabs(x)<esp)
        return 0;
    return x>0?1:-1;
}
double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double mult(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
bool judge(line l1,line l2)
{
    int a1=sign(max(l1.st.x,l1.ed.x)-min(l2.st.x,l2.ed.x));
    int a2=sign(max(l2.st.x,l2.ed.x)-min(l1.st.x,l1.ed.x));
    int a3=sign(max(l1.st.y,l1.ed.y)-min(l2.st.y,l2.ed.y));
    int a4=sign(max(l2.st.y,l2.ed.y)-min(l1.st.y,l1.ed.y));
    int a5 = sign(mult(l1.st,l1.ed,l2.st));
    int a6 = sign(mult(l1.st,l1.ed,l2.ed));
    int a7 = sign(mult(l2.st,l2.ed,l1.st));
    int a8 = sign(mult(l2.st,l2.ed,l1.ed));
    if(a1<0||a2<0||a3<0||a4<0)
        return 0;
    if(a5*a6<0&&a7*a8<0)
        return 1;
    return 0;
}
int main()
{
    int n;
    scanf("%d",&n);
    if(n==0)
    {
        printf("Number of doors = 1\n");
        return 0;
    }
    point ba;
    int np=0;
    for(int i=0; i<n; i++)
    {
        cin>>l[i].st.x>>l[i].st.y>>l[i].ed.x>>l[i].ed.y;

        p[np].x=l[i].st.x,p[np++].y=l[i].st.y;

        p[np].x=l[i].ed.x,p[np++].y=l[i].ed.y;
    }
    p[np].x=0,p[np++].y=0;
    p[np].x=0,p[np++].y=100;
    p[np].x=100,p[np++].y=100;
    p[np].x=100,p[np++].y=0;
    line lz;
    int ans=inf;
    cin>>lz.st.x>>lz.st.y;
    ///枚举每个端点和宝藏坐标,会与多少条线段相交、
    for(int i=0; i<np; i++)
    {
        int num=1;
        lz.ed.x=p[i].x,lz.ed.y=p[i].y;
        for(int j=0; j<n; j++)
        {
            if(judge(lz,l[j]))
            {
                num++;
            }
        }
        ans=min(ans,num);
    }
    printf("Number of doors = %d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/86502959
今日推荐