Wolf and Rabbit

欢迎访问https://blog.csdn.net/lxt_Lucia~~

宇宙第一小仙女\(^o^)/~~萌量爆表求带飞=≡Σ((( つ^o^)つ~dalao们点个关注呗~~



Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input

 
    
2 1 2 2 2
 

Sample Output

 
  
NO YES


题意:就是狼想捉兔子,兔子就躲在这n个洞里的其中一个藏着,狼从第0个洞开始,隔m个一直搜,如果搜不到兔子,兔子就幸运的活下去了,能活下去就YES,不能就NO。


Hint:s说白了就是看两个数是不是互质,也就是看最大公约数是不是1,如果有公约数,就有重复的,也就是不能遍历完,printf YES。


------------------------------------------------------------------我只是一条可爱的分界线-------------------------------------------------------------


#include<bits/stdc++.h>
int main()
{
    int T,i;
    long long m,n,t;
    scanf("%d",&T);
    for(i=1;i<=T;i++){
        scanf("%lld%lld",&m,&n);
        while(n!=0){
            t=n;
            n=m%n;
            m=t;
        }
        if(m==1)
            printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}


宇宙第一小仙女\(^o^)/~~萌量爆表求带飞=≡Σ((( つ^o^)つ~dalao们没事多来瞅瞅咯~~

欢迎访问https://blog.csdn.net/lxt_Lucia~~

猜你喜欢

转载自blog.csdn.net/lxt_lucia/article/details/79718965
今日推荐