(难)A1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:

有N (≤40,000)个学生,K(≤2,500)门课,现在给出选择每门课的学生姓名,并在之后给出N个学生的姓名,要求按顺序给出每个学生的选课情况。

知识点:

vector

  1. 添加头文件 #include <vector>, 以及 using namespace std;
  2. 定义:vector<typename> name; 相当于一位数组 name[SIZE], 只不过其长度可以根据需要进行变化,比较节省空间,“变长数组”
  3. 二维 vector 数组定义:vector[typrname] Arrayname[arraysize], 即 Arrayname[] 中的每一个元素都是一个 vector, Arrayname[0] ~ Arrayname[arraysize - 1] 中每一个都是一个 vector容器
  4. push_back(), 在 vector 之后添加一个元素 x
  5. size() , 获取 vector 中元素个数
  6. selectCourse[id][j], 获取二维数组的元素值
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int N = 40010;
const int M = 26*26*26*10 + 1;
vector<int> selectCourse[M];

int getID(char name[]){
  int id = 0;
  for(int i = 0; i < 3; i++){
    id = id * 26 + (name[i] - 'A');
  }
  id = id * 10 + (name[3] - '0');
  return id;
}

int main(){
  char name[5];
  int n, k;
  scanf("%d %d", &n, &k);
  for(int i = 0; i < k; i++){
    int course, x;
    scanf("%d %d", &course, &x);
    for(int j = 0; j < x; j++){
      scanf("%s", name);
      int id = getID(name);
      selectCourse[id].push_back(course);
    }
  }
  for(int i = 0; i < n; i++){
    scanf("%s", name);
    int id = getID(name);
    sort(selectCourse[id].begin(),selectCourse[id].end());
    printf("%s %d", name, selectCourse[id].size());
    for(int j = 0; j < selectCourse[id].size(); j++){
      printf(" %d", selectCourse[id][j]);
    }
    printf("\n");
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87564095
今日推荐