1039 Course List for Student (25 分)

dZhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

完成后的代码:

#include "cstdio"

#include "cstring"

#include "vector"

#include "algorithm"

using namespace std;

int getId(char *name){ //使用哈希将字符串转化为十进制数

int id=0;

for (int i=0; i<3; i++) {

id=id*26+name[i]-'A';

}

id=id*10+name[3]-'0';

return id;

}

int main(){

char name[5];

vector<int> student[26*26*10*26+1000]; //开辟一个大到足以容纳字符串哈希变化之后的数组

int query_number,course_number;

scanf("%d %d",&query_number,&course_number); //输入查询人数 课程总数

for (int i=0; i<course_number; i++) {

int index,stu_number; //复用一个变量使得代码变得简洁

scanf("%d %d",&index,&stu_number);

for (int j=0; j<stu_number; j++) { //对每个课程 每输入一个课程内的学生名字,就在该名字哈希变化后的数组中将课程号保存

scanf("%s",name);

student[getId(name)].push_back(index); //保存课程号

}

}

for (int i=0; i<query_number; i++) {

scanf("%s",name);

printf("%s %lu",name,student[getId(name)].size()); //输出

sort(student[getId(name)].begin(), student[getId(name)].end()); //sort函数不能直接传入vector,需要调用begin和end函数

for (vector<int>::iterator it=student[getId(name)].begin(); it!=student[getId(name)].end(); it++) {

printf(" %d",*it);

}

if (i!=query_number-1) {

printf("\n");

}

}}

反思:

  • 首先是代码简洁度的问题,要保持代码简洁,需要留意变量复用,还有许多变量需要提前处理定义
  • 字符串hash的问题,字符串hash需要注意在空间足够的情况下最后不要出现重复位置处理,而是将空间开大一点,通常字符串处理只有大写则为*26,大小写则为*52,如果还存在数字在末尾可以*10来处理数字,不然就当做字母*62
发布了14 篇原创文章 · 获赞 0 · 访问量 146

猜你喜欢

转载自blog.csdn.net/Yanhaoming1999/article/details/102723762
今日推荐