PAT (Advanced Level) Practice — 1039 Course List for Student (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37345402/article/details/88046950

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805447855292416

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

zs存储每门课的学生姓名,用map存储学生姓名,将学生姓名映射到数字上,枚举每一门课程,枚举每一个学生,用s记录该学生的每门课编号。

#include<bits/stdc++.h>
using namespace std;
int main(){	
	ios::sync_with_stdio(false);
	cin.tie(0);
	int n,k;
	cin>>n>>k;
	map<string,int>p;
	p.clear();
	vector<int>s[44444];
	vector<string>zs[2550];
	int cno,sp;
	string sna;
	for(int i=0;i<k;i++)
	{
		cin>>cno>>sp;
		for(int j=0;j<sp;j++)
		{
			cin>>sna;
			zs[cno].push_back(sna);//记录每门课的学生 
		}
	}
	string stu[44444];
	for(int i=1;i<=n;i++)
	{
		cin>>stu[i];
		p[stu[i]]=i;
	}
	for(int i=1;i<=k;i++)
	{
		int l=zs[i].size();//第i个课程有多少个学生 
		for(int j=0;j<l;j++)//s[i][j]表示第i个学生的第j门课的编号 
		{
			s[p[zs[i][j]]].push_back(i);//存该学生上的哪门课 
		}
	}
	for(int i=1;i<=n;i++)
	{
		cout<<stu[i];
		int l=s[i].size();
		cout<<" "<<l;
		for(int j=0;j<l;j++)
		cout<<" "<<s[i][j];
		cout<<endl;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/m0_37345402/article/details/88046950
今日推荐