T - Sightseeing trip

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

题解:题目要求最小环。这里我们可以把一个  i->i 的环拆成  i->k 的直接距离+ k->j 的直接距离 + i->j 的最短距离。为了保证i->j的最短距离不包含k这个点,我们可以将k设为最大的点,通过枚举k来更新最小环。

#include<iostream>
#include<cstring>
using namespace std;
const int INF=2000;     //设置为0x3f3f3f3f会在下列计算的时候导致溢出而出错
int dis[111][111],mp[111][111],path[111],pre[111][111],cnt,ans,n,m;
void  Floyd()
{
    for(int k=1;k<=n;k++)   
    {
        for(int i=1;i<k;i++)
        {
            for(int j=i+1;j<k;j++)
            {
                if(ans>mp[i][k]+mp[k][j]+dis[i][j]) //成环条件,取最小值
                {
                    ans=mp[i][k]+mp[k][j]+dis[i][j];
                    cnt=0;
                    int t=j;
                    while(t!=i)         //寻找路径
                    {
                        path[++cnt]=t;
                        t=pre[i][t];
                    }
                    path[++cnt]=i;
                    path[++cnt]=k;
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(dis[i][j]>dis[i][k]+dis[k][j])
                {
                    dis[i][j]=dis[i][k]+dis[k][j];
                    pre[i][j]=pre[k][j];
                }
            }
        }
    }
}
int main()
{

    cin>>n>>m;
    ans=INF;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            pre[i][j]=i;
            mp[i][j]=mp[j][i]=dis[i][j]=dis[j][i]=INF;
        }
    }
    for(int i=1;i<=m;i++)
    {
        int u,v,w;
        cin>>u>>v>>w;
        dis[u][v]=dis[v][u]=mp[u][v]=mp[v][u]=min(mp[u][v],w);
    }
    Floyd();
    if(ans==INF)
        cout<<"No solution."<<endl;
    else
    {
        for(int i=1;i<cnt;i++)
            cout<<path[i]<<" ";
        cout<<path[cnt]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43824158/article/details/86837273