poj 1734 Sightseeing trip

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

 题目大意:

寻找一个节点数大于2的最小自环输出其路径

用Floyd寻找自环,

在用Floyd()松弛之前,对于当前的每一个k,都可以看成存在以k为起点和终点的环(k点为环中最大的点),并且环中的所有边都没有被k松弛过。 

所以在松弛前先找最小环,nmap i k + nmap j k +d i j

记录路径path i j = k

#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<string>
#include<cstring>

#define ll long long

#define mem(a,b) memset(a,b,sizeof(a))


const int maxn=1e6+5;
const int inf=1e8;

using namespace std;

int nmap[105][105];
int path[105][105],n,m,d[105][105],minn=inf,mub;
int ans[1005];

int main(){
    cin>>n>>m;
    //for(int i=1;i<=n;i++){nmap[i][i]=0;d[i][i]=0;}
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            path[i][j]=i;
            nmap[i][j] = d[i][j] = inf;
        }
    }
    for(int i=1;i<=m;i++)
    {
        int u,v,w;
        scanf("%d%d%d",&u,&v,&w);
        if(nmap[u][v]>w)
        {
            nmap[u][v]=w;
            nmap[v][u]=w;
            d[u][v]=w;
            d[v][u]=w;
        }
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<k;i++)
        {
            for(int j=i+1;j<k;j++)
            {
                if(minn>nmap[k][i]+nmap[k][j]+d[i][j])
                {
                    minn=nmap[i][k]+nmap[k][j]+d[j][i];
                    int t=j;
                    mub=0;
                    while(t!=i)
                    {
                        ans[mub++]=t;
                        t=path[i][t];
                    }
                    ans[mub++] = i;
                    ans[mub++] = k;
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(d[i][j]>d[i][k]+d[k][j])
                {
                    d[i][j]=d[i][k]+d[k][j];
                    path[i][j]=path[k][j];
                }
            }
        }
    }
    if(minn==inf) printf("No solution.\n");
    else
    {
        for(int i=0;i<mub;i++)
        {
            printf("%d",ans[i]);
            if(i==mub-1) printf("\n");
            else printf(" ");
        }
    }
//    for(int i=1;i<=n;i++)
//    {
//        for(int j=1;j<=n;j++)
//            cout<<nmap[i][j]<<" ";
//            cout<<endl;
//    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40703941/article/details/86567548