1068 Find More Coins (30 分)记忆化搜索

1068 Find More Coins (30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (104​​, the total number of coins) and M (102​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1​​V2​​Vk​​ such that V1​​+V2​​++Vk​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution
思路
  1、把给出硬币值按从小到大排序,这样最先找到的那个解就是这个题目的解
  2、就是否选择第i个硬币进行枚举,使用dp数组记录状态。
#include<iostream>
#include<string>
#include<vector>
#include<string>
#include<cstdio>
#include<cmath>
#include<string.h>
#include<algorithm>
using namespace std;

vector<int>result;

int dp[10004][103];

bool res(int a[],int n,int sum,int i)
{

    if(sum==0)
        return true;
    if(i>=n)
        return false;
    if(sum<a[i])
    {
        dp[i][sum]=0;
        return false;
    }
    if(dp[i][sum]!=-1)
        return dp[i][sum];
    if(res(a,n,sum-a[i],i+1))
    {
        dp[i][sum]=1;
       // printf("%d %d\n",i,a[i]);
        result.push_back(a[i]);
        return true;
    }
    else
    {
        dp[i][sum]=0;
        return res(a,n,sum,i+1);
    }
}

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int a[n];
    for(int i=0; i<n; i++)
        scanf("%d",&a[i]);
    sort(a,a+n);
    memset(dp,-1,sizeof(dp));
    if(res(a,n,m,0))
    {
        reverse(result.begin(),result.end());
        printf("%d",result[0]);
        for(int i=1;i<result.size();i++)
            printf(" %d",result[i]);
        return 0;
    }
    printf("No Solution");
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/zhanghaijie/p/10371807.html
今日推荐