1068 Find More Coins(30 分)(cj)

1068 Find More Coins(30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V​2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

俩种方法,a:  dps加剪枝,b:  01背包求路径。

 b: 查找路径是从后往前找,可以先把硬币从大到小排序,这样从后往前找路径的情况下 第一次找到既是最小数列。 

#pragma warning(disable:4996)
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
using namespace std;
bool choice[10004][104];
bool cmp(const int& a, const int &b);
int main(){
	int n, m, x;
	cin >> n >> m;
	vector<int> varr;
	vector<int> dp(m+5);
	for (int i = 0; i < n; ++i) {
		cin >> x;
		varr.push_back(x);
	}
	sort(varr.begin(), varr.end(), cmp);
	vector<int> vres;
	for (int i = 0; i < varr.size(); ++i) {
		for (int j = m; j >= varr[i]; --j) {
			if (dp[j - varr[i]] + varr[i] >= dp[j]) {
				choice[i][j] = true;
				dp[j] = dp[j - varr[i]] + varr[i];
			}
		}
	}
	if (dp[m] != m) {
		cout << "No Solution" << endl;
	}
	else {
		vector<int> vres;
		int pos = m;
		for (int i = n - 1; i >= 0; --i) {
			if (choice[i][pos]) {
				vres.push_back(varr[i]);
				pos -= varr[i];
			}
		}
		//sort(vres.begin(), vres.end());
		for (int i = 0; i < vres.size(); ++i) {
			if (i != 0)cout << ' ';
			cout << vres[i];
		}
	}
	system("pause");
	return 0;
}
bool cmp(const int& a, const int& b) {
	return a > b;
}

a: dps 的缺点就是容易被卡时间,通过剪枝能节省大量时间,但是本身时间基数就很大。所以有些特例需要特判。

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool dps(vector<int>& varr, int pos, int x);
vector<int> vres;
bool f = 1;
int main() {
	int n, m, x;
	vector<int> varr;
	cin >> n >> m;
	int sum = 0;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		sum+=x;
		varr.push_back(x);
	}
	if (sum < m) {
		cout << "No Solution" << endl;
		return 0;
	}
	sort(varr.begin(), varr.end());
	bool res = dps(varr, 0, m);
	if (vres.size()==0) {
		cout << "No Solution" << endl;
	}
	else {
		for (int i = 0; i < vres.size(); ++i) {
			if (i != 0) cout << ' ';
			cout << vres[i];
		}
		cout << endl;
	}

	system("pause");
	return 0;
}
bool dps(vector<int>& varr, int pos, int x) {
	int border = varr.size() - 1;
	if (x == 0) return 1;
	if (x < 0) return 0;
	for (int i = pos; i <= border; ++i) {
		if (x < varr[i]) break;
		vres.push_back(varr[i]);
		if (dps(varr, i + 1, x - varr[i]) == 1) return 1;
		vres.pop_back();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82283906