POJ - 迷宫问题 (BFS) (打印路径) (day_5_H)

版权声明:商业转载请联系作者获得授权,非商业转载请注明出处。 https://blog.csdn.net/weixin_43939327/article/details/86661641

迷宫问题

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37943 Accepted: 21280
Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

题目分析:

炒鸡简单的BFS,每个状态加一个数组来保存走过的路径即可。

代码实现:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
//#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
#define pf          printf
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define ms(i,j) memset(i,j,sizeof(i))

int a[5][5],mark[5][5];
struct s
{
    int x,y,s,m[28][2];
}temp,now;
void bfs()
{
    ms(mark,0);
    queue<s> line;
    temp.s=0;
    temp.x=0;
    temp.y=0;
    temp.m[0][0]=0;
    temp.m[0][1]=0;
    line.push(temp);
    while(!line.empty())
    {
        now=line.front();
        line.pop();
        if(now.x==4&&now.y==4)
        {
            for(int i=0;i<=now.s;i++)
                printf("(%d, %d)\n",now.m[i][0],now.m[i][1]);
            return;
        }
        if(now.x>0&&!mark[now.x-1][now.y]&&!a[now.x-1][now.y])
        {
            temp=now;
            temp.x-=1;
            mark[temp.x][temp.y]=1;
            temp.s+=1;
            temp.m[temp.s][0]=temp.x;
            temp.m[temp.s][1]=temp.y;
            line.push(temp);
        }
        if(now.x<4&&!mark[now.x+1][now.y]&&!a[now.x+1][now.y])
        {
            temp=now;
            temp.x+=1;
            mark[temp.x][temp.y]=1;
            temp.s+=1;
            temp.m[temp.s][0]=temp.x;
            temp.m[temp.s][1]=temp.y;
            line.push(temp);
        }
        if(now.y>0&&!mark[now.x][now.y-1]&&!a[now.x][now.y-1])
        {
            temp=now;
            temp.y-=1;
            mark[temp.x][temp.y]=1;
            temp.s+=1;
            temp.m[temp.s][0]=temp.x;
            temp.m[temp.s][1]=temp.y;
            line.push(temp);
        }
        if(now.y<4&&!mark[now.x][now.y+1]&&!a[now.x][now.y+1])
        {
            temp=now;
            temp.y+=1;
            mark[temp.x][temp.y]=1;
            temp.s+=1;
            temp.m[temp.s][0]=temp.x;
            temp.m[temp.s][1]=temp.y;
            line.push(temp);
        }
    }
}
int main()
{
    for(int i=0;i<5;i++)
        for(int j=0;j<5;j++)
            sf(a[i][j]);
    bfs();
}

猜你喜欢

转载自blog.csdn.net/weixin_43939327/article/details/86661641