POJ - 2585 Window Pains

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows: 

1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1  and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?

. . . and so on . . . 
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 

  1. Start line - A single line: 
    START 
     
  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 


After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

题目大意:电脑屏幕的大小为4*4,每个应用程序窗口的大小为2*2,每个应用程序窗口在电脑屏幕的位置是固定的,一共有9个应用程序,后面打开的应用程序为覆盖前面打开的应用程序,给出电脑屏幕上最终的状态,问电脑有没有出故障,应用程序窗口覆盖方式正确 则电脑没有出故障

解题思路:电脑屏幕16个位置中每一个位置出现的应用程序数量是一定的,那么屏幕上该位置最终显示的应用程序一定是最后打开的,那么我们就可以建立一种优先关系,比如在屏幕16的位置用二维数组表示,那么a[2][2]只可能出现应用程序5,6,8,9,这四个,第一个样例中屏幕该位置显示的应用程序是6,也就是说,不管该位置那个应用程序先出现,最终程序6一定是最后出现的,这时程序5,8,9出现一定出现在程序6打开之前,显然这些程序之前有这这种优先关系,判断最后每个位置出现情况是否符合,当然想到拓扑排序,如果电脑没有故障,每个位置根据优先关系建立边,改图一定不成环

AC代码:

#include<iostream>
#include<cstring>
#include<string>
#include<queue>
using namespace std;

int num[4][4][4]={ { {1},{1,2},{2,3},{3} },
				   { {1,4},{1,2,4,5},{2,3,5,6},{3,6} },
				   { {4,7},{4,5,7,8},{5,6,8,9},{6,9} },
				   { {7},{7,8},{8,9},{9} }
				 };//每个位置可能出现的程序 
int degree[10];
int map[10][10];

int toposort()
{
	int cnt=0;
	for(int i=1;i<=9;i++)
	{
		for(int j=1;j<=9;j++)
		{
			if(!degree[j])
			{
				cnt++;
				degree[j]--;
				for(int k=1;k<=9;k++)
				{
					if(map[j][k])
						degree[k]--;
				}
			}
		} 
	}
	return cnt;
}
int main()
{
	string str,str1="ENDOFINPUT";
	while(cin>>str,str!=str1)
	{
		memset(degree,0,sizeof(degree));
		memset(map,0,sizeof(map));
		int x;
		for(int i=0;i<4;i++)
		for(int j=0;j<4;j++)
		{
			cin>>x;
			for(int k=0;k<4;k++)
			{
				if(num[i][j][k]==0)
					break;
				if(num[i][j][k]!=x)
				{
					if(!map[num[i][j][k]][x])
					{
						map[num[i][j][k]][x]=1;//每种关系建立一条边 
						degree[x]++;
					}
				}
			}
		}
		cin>>str;
		if(toposort()==9)//不成环 
			cout<<"THESE WINDOWS ARE CLEAN"<<endl;
		else
			cout<<"THESE WINDOWS ARE BROKEN"<<endl;
	
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/86649992