Sliding Window@POJ 2823

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题目分析:单调队列基础题。

index队列记录的是que队列中每个数的下标,严格一一对应,即二者的增删要同步。

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cstdio>
#include <stack>
#include <deque>
#include <set>
#define MAXN 1000003
using namespace std;

int n,k;
int a[MAXN];

void get_min(){
    deque<int> que,index; //que是单调队列,index严格对应que中每个数的下标
    vector<int> vec;
    for(int i=0;i<k&&i<n;++i){
        while(!que.empty() && que.back() > a[i]){
            que.pop_back();
            index.pop_back();
        }
        que.push_back(a[i]);
        index.push_back(i);
    }
    vec.push_back(que.front());
    for(int i=k;i<n;++i){
        while(!que.empty() && que.back() > a[i]){
            que.pop_back();
            index.pop_back();
        }
        que.push_back(a[i]);
        index.push_back(i);
        while(index.front() <= i-k && !index.empty()){ //验证队首的数是不是超出k的范围了
            que.pop_front();
            index.pop_front();
        }
        vec.push_back(que.front());
    }
    cout << vec[0];
    for(int i=1;i<vec.size();++i) cout << ' ' << vec[i];
    cout << endl;
}

void get_max(){
    deque<int> que,index;
    vector<int> vec;
    for(int i=0;i<k&&i<n;++i){
        while(!que.empty() && que.back() < a[i]){
            que.pop_back();
            index.pop_back();
        }
        que.push_back(a[i]);
        index.push_back(i);
    }
    vec.push_back(que.front());
    for(int i=k;i<n;++i){
        while(!que.empty() && que.back() < a[i]){
            que.pop_back();
            index.pop_back();
        }
        que.push_back(a[i]);
        index.push_back(i);
        while(index.front()<=i-k && !index.empty()){
            index.pop_front();
            que.pop_front();
        }
        vec.push_back(que.front());
    }
    cout << vec[0];
    for(int i=1;i<vec.size();++i) cout << ' ' << vec[i];
    cout << endl;
}

int main(){
    while(~scanf("%d%d",&n,&k)){
        for(int i=0;i<n;++i) scanf("%d",&a[i]);
        get_min();
        get_max();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39021458/article/details/81317293
今日推荐