POJ 2585 Window Pains(拓扑排序 || 全排列)

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux’s windows would be represented by the following 2 x 2 windows:
这里写图片描述
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?
… and so on …
Unfortunately, Boudreaux’s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in …

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:

1.Start line - A single line: START

2.Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux’s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.

3.End line - A single line: END

After the last data set, there will be a single line:
ENDOFINPUT

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux’s screen, the output will be a single line with the statement:

THESE WINDOWS ARE CLEAN

Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN


题意

在4X4的屏幕中,存在如图9块固定位置的2X2窗口(可相互覆盖) ,问窗口显示是否正常

思路

一开始看到只有9种窗口,立马想到了全排列直接暴力,竟然真a了
后来才知道有拓扑排序的写法,因为这9个窗口必定不能互相覆盖。
例如1->2->4->1
4×4的屏幕中,每点可能存在的数字是一个集合V,如果某点出现了某个数字x,那么x覆盖V-x
所以只需对于4×4的每个位置,建立x到V-x中所有元素的单向边,图如果无环则正常


暴力:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char s[15];
int cmp1[4][4], cmp[4][4], data[10][4][4];
int v[10];

bool judge()
{
    for(int i = 0; i < 4; i++) for(int j = 0; j < 4; j++) if(cmp[i][j] != cmp1[i][j]) return 0;
    return 1;
}

int main()
{
    memset(data,0,sizeof(data));
    for(int i = 1; i <= 9; i++)
    {
        for(int j = (i-1)/3; j <= (i-1)/3 + 1; j++)
        {
            for(int k = (i-1)%3; k <= (i-1)%3 + 1; k++)
            {
                data[i][j][k] = i;
            }
        }
    }
    while(scanf("%s",s),s[2] == 'A')
    {
        for(int i = 0; i < 4; i++) for(int j = 0; j < 4; j++) scanf("%d",&cmp1[i][j]);
        for(int i = 0; i < 10; i++) v[i] = i;

        int flag = 0;
        do
        {
            for(int i = 1; i < 10; i++)
            {
                for(int j = 0; j < 4; j++)
                {
                    for(int k = 0; k < 4; k++)
                    {
                        if(data[v[i]][j][k]) cmp[j][k] = data[v[i]][j][k];
                    }
                }
            }
            if(judge()) {flag = 1; break;}
        }while(next_permutation(v+1,v+10));

        if(flag) printf("THESE WINDOWS ARE CLEAN\n");
        else printf("THESE WINDOWS ARE BROKEN\n");
        scanf("%s",s);
    }
    return 0;
}

拓扑排序:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;

int e[15][15], indeg[15];
char s[15];

bool topsort()
{
    int cnt = 0;
    queue<int> q;
    for(int i = 1; i < 10; i++) if(!indeg[i]) q.push(i);
    while(!q.empty())
    {
        int now = q.front();
        q.pop();
        cnt++;
        for(int i =  1; i < 10; i++)
        {
            if(!e[now][i]) continue;
            indeg[i] -= e[now][i];
            if(!indeg[i]) q.push(i);
        }
    }
    return cnt == 9;
}

int main()
{
    vector<int> v[10][10];
    for(int i = 1; i <= 9; i++)
        for(int j = (i-1)/3; j <= (i-1)/3 + 1; j++)
            for(int k = (i-1)%3; k <= (i-1)%3 + 1; k++)
                v[j][k].push_back(i);

    while(scanf("%s",s),s[2] == 'A')
    {
        memset(e,0,sizeof(e));
        memset(indeg,0,sizeof(indeg));
        int u;
        for(int i = 0; i < 4; i++)
        {
            for(int j = 0; j < 4; j++)
            {
                scanf("%d",&u);
                for(int k = 0; k < v[i][j].size(); k++)
                {
                    if(u == v[i][j][k]) continue;
                    e[u][v[i][j][k]]++;
                    indeg[v[i][j][k]]++;
                }
            }
        }

        if(topsort()) printf("THESE WINDOWS ARE CLEAN\n");
        else printf("THESE WINDOWS ARE BROKEN\n");
        scanf("%s",s);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/j2_o2/article/details/81094595