poj 2823 Sliding Window

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 67208   Accepted: 19082
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意:求滑动块中最大最小值
思路:单调队列
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
#define INF 0x3f3f3f3f
#define N_MAX 1000000+20
typedef long long ll;
int n, k;
int a[N_MAX],deq[N_MAX],Min[N_MAX],Max[N_MAX];

int main() {
    while (scanf("%d%d",&n,&k)!=EOF) {
        for (int i = 0; i < n; i++)
            scanf("%d",&a[i]);
        int s = 0, t = 0;
        for (int i = 0; i < n;i++) {
            while (s < t&&a[deq[t - 1]] >= a[i])t--;
            deq[t++] = i;
            if (i - k + 1 >= 0) {
                Min[i - k + 1] = a[deq[s]];
                if (deq[s] == i - k + 1)
                    s++;
            }
        }
         s = 0, t = 0;
         for (int i = 0; i < n;i++) {
             while (s < t&&a[deq[t - 1]] <= a[i])t--;
             deq[t++] = i;
             if (i - k + 1 >= 0) {
                 Max[i - k + 1] = a[deq[s]];
                 if (deq[s] == i - k + 1)s++;
             }
         }
        for (int i = 0; i <= n-k; i++)
            printf("%d%c",Min[i],i==n-k?'\n':' ');
        for (int i = 0; i <= n-k; i++)
            printf("%d%c", Max[i], i== n-k ? '\n' : ' ');
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/ZefengYao/p/9031902.html