POJ1456 ZOJ1731 UVA1316 UVALive2757 Supermarket【贪心+并查集】

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15260   Accepted: 6878

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.  
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.  

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.  

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source



Regionals 2003 >> Europe - Southeastern


问题链接POJ1456 ZOJ1731 UVA1316 UVALive2757 Supermarket

问题简述

  N件商品,给出商品的价值和销售截止期限,最后期限之前销售处能够得到利润,每个单位时间只能销售1件商品,求最大利润。

问题分析

  这个问题明显是用贪心法来解决。按照价值从大到小排序,优先卖出价值高的,在其截止的时间点卖出。如果那个时间已经卖出某个商品,则找截止时间之前的时间点卖出。

  实现这个问题的时候,可以用搜索法,也可以用并查集来实现。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序(搜索)如下:

/* POJ1456 ZOJ1731 UVA1316 UVALive2757 Supermarket */

#include <iostream>
#include <algorithm>
#include <queue>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 10000;
struct Prod {
    int p, d;
} p[N + 1];
bool vis[N + 1];

bool cmp(Prod a, Prod b)
{
    return a.p > b.p;
}

int main()
{
    int n;
    while(scanf("%d", &n) == 1) {
        for(int i = 1; i <= n; i++)
            scanf("%d%d", &p[i].p, &p[i].d);

        sort(p + 1, p + 1 + n, cmp);

        int ans = 0;
        memset(vis, false, sizeof(vis));
        for(int i = 1; i <= n; i++) {
            if(vis[p[i].d]) {
                for(int j = p[i].d - 1; j >=1; j--)
                    if(!vis[j]) {
                        ans += p[i].p;
                        vis[j] = true;
                        break;
                    }
            } else {
                ans += p[i].p;
                vis[p[i].d] = true;
            }
        }

        printf("%d\n", ans);
    }

    return 0;
}




AC的C++语言程序(并查集)如下:

/* POJ1456 ZOJ1731 UVA1316 UVALive2757 Supermarket */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 10000;
int f[N + 1];
int Find(int a)
{
    return f[a] == -1 ? a : f[a] = Find(f[a]);
}

struct Prod {
    int p, d;
} p[N];

bool cmp(Prod a, Prod b)
{
    return a.p > b.p;
}

int main()
{
    int n;
    while(scanf("%d", &n) == 1) {
        memset(f, -1, sizeof(f));

        for(int i = 0; i < n; i++)
            scanf("%d%d", &p[i].p, &p[i].d);

        sort(p, p + n, cmp);

        int ans = 0;
        for(int i = 0; i < n; i++) {
            int pd = Find(p[i].d);
            if(pd > 0) {
                ans += p[i].p;
                f[pd] = pd - 1;
            }
        }

        printf("%d\n", ans);
    }

    return 0;
}





猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80277869