POJ - 1456 Supermarket 位置并查集+贪心 or 堆+贪心

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ  x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.



堆加贪心思路很简单,主要看看并查集加贪心

:建立一个关于天数的并查集,将物品按价值从大到小排序,依次加入并查集中(贪心),加入的位置为当前过期的天数往前的第一个空闲的位置(天数)(按价值排序了,那个位置肯定是他的);



并查集代码47ms

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<cctype>
using namespace std;
#define ll long long
const int len=1e4+5;
typedef pair<int,int>P;
struct ss{
	int w,d;
}arr[len];
bool cmp(ss a,ss b)
{
	if(a.w==b.w)return a.d<b.d;
	return a.w>b.w;
}
int f[len];
int find(int x)
{
	return x==f[x]?x:f[x]=find(f[x]);
}
int main() 
{
	int n;
	while(cin>>n)
	{
		int m=0;
		for(int i=1;i<=n;++i)
		{
			scanf("%d%d",&arr[i].w,&arr[i].d);
			m=max(m,arr[i].d);//记录最晚天 
		}
		sort(arr+1,arr+1+n,cmp);//按钱大到小排序 
		ll ans=0;
		for(int i=1;i<=m;++i)f[i]=i;//初始化 
		for(int i=1;i<=n;++i)
		{
			int x=find(arr[i].d);//x为物品i可以使用的最晚的那一天; 
			if(x==0)continue; 
			ans+=arr[i].w;//还有位置 
			f[x]=find(x-1);//减少一个位置 
		}
		cout<<ans<<endl;
	}
}

贪心79ms

#include<iostream>  
#include<cstdio>  
#include<algorithm>
#include<cmath>
#include<queue> 
#include<cstring>
using namespace std;  
#define ll long long  
typedef pair<int,int>P;
const int len=1e4+4;
P arr[len];
bool cmp(P a,P b)
{
	if(a.second==b.second)return a.first>b.first;
	return a.second<b.second;
}
int main()  
{  
	int n;
	while(cin>>n)
	{
		for(int i=0;i<n;++i)
			scanf("%d%d",&arr[i].first,&arr[i].second);
		sort(arr,arr+n,cmp);
		ll ans=0;
		priority_queue<int,vector<int>,greater<int> >qu;
		for(int i=0;i<n;++i)
		{
			if(qu.size()==arr[i].second)
			{
				if(qu.size())
				{
					int x=qu.top();
					if(arr[i].first>x)
					{
						qu.pop();
						qu.push(arr[i].first); 
					}
				} 
			}
			else 
			if(qu.size()<arr[i].second) 
			qu.push(arr[i].first);
		}
		while(qu.size())
		{
			ans+=qu.top();
			qu.pop();
		}
		cout<<ans<<endl;
	}
}  

猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/80753292