POJ1013称硬币【枚举】

Counterfeit Dollar
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 52474   Accepted: 16402

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

大概意思就是有12枚硬币从A到L,其中有一枚是假币,但是不知道轻重。称了三次,每次给定左边硬币和右边硬币以及右边天秤的情况,三次称量一定会确定一枚假币,问哪个硬币是假的并说明假币轻了还是重了。
 
思路:把十二枚硬币的情况都枚举一遍,一枚硬币如果是假币会有是轻假币还是重假币的情况,都需要枚举出来。从A到L依次假设为假币,看是否符合三次称量,因为只有一个假币,所以肯定只有一个硬币是假币时,才会满足给出的三次测量的情形。
#include<iostream>
#include<string.h>
using namespace std;
char cleft[3][7];//一共12个硬币,每次一边最多6个
char cright[3][7];
char result[3][7]; 
int num;
bool isFake(char c,bool heavy);//不加括号体 
int main()
{

	cin >> num;
	while(num-- !=0)
	{
		for(int i = 0;i<3;i++)
		{
			cin >> cleft[i] >>cright[i]>>result[i];
		}
		for(char i = 'A';i<='L';++i)
		{
			if(isFake(i,true))
			{
				cout <<i<<" is the counterfeit coin and it is heavy. "<<endl;
				break;
			}
			else if(isFake(i,false))
			{
				cout <<i<<" is the counterfeit coin and it is light. "<<endl;
				break;
			}
		}
	}
	return 0;
}

bool isFake(char c,bool heavy)
{
	for(int i = 0;i<3;++i)
	{
		switch(result[i][0])
		{
			case 'u':
				if(heavy == true && strchr(cleft[i],c)==NULL )//重 假币肯定在左边
						return false;
				if(heavy == false && strchr(cright[i],c)==NULL )//轻 假币肯定在右边
						return false;
				break;		
			case 'd':
				if(heavy == true && strchr(cright[i],c)==NULL )//假币肯定在右边,并且重 
						return false;
				if(heavy == false && strchr(cleft[i],c)==NULL )//假币肯定在左边,并且轻 
						return false;
				break;		
			case 'e':
				if(strchr(cleft[i],c)!=NULL || strchr(cright[i],c)!=NULL  )//假币不在两边 
						return false;
				break;	
		}
	}
	return true;
}

strchr语法:
  #include <string.h>
  char *strchr( const char *str, int ch );
功能:函数返回一个指向str 中ch 首次出现的位置,当没有在str 中找ch到返回NULL。

猜你喜欢

转载自www.cnblogs.com/knmxx/p/10308264.html