HDU 5536 Chip Factory【暴力大法好】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/86504303

题目:

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the ii-th chip produced this day has a serial number sisi. 

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below: 

which i,j,ki,j,k are three different integers between 11 and nn. And ⊕⊕ is symbol of bitwise XOR. 

Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer TT indicating the total number of test cases. 

The first line of each test case is an integer nn, indicating the number of chips produced today. The next line has nn integers s1,s2,..,sns1,s2,..,sn, separated with single space, indicating serial number of each chip. 

1≤T≤10001≤T≤1000 
3≤n≤10003≤n≤1000 
0≤si≤1090≤si≤109 
There are at most 1010 testcases with n>100n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

题目大意:

求max( (a[i] + a[j]) ^ a[k] ) (i, j, k都不相同)  ^异或(i,j,k<n且互不相同);

解题思路:

三重循环寻找最大值。

实现代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int cal(int i,int j,int k){
    int a1=(i+j)^k;
    int a2=(i+k)^j;
    int a3=(k+j)^i;
    return max(a1,max(a2,a3));
}
int main(){
    int t,n,s[1001];
    scanf("%d",&t);
    while(t--){
        int ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&s[i]);
        }
        for(int i=1;i<=n-2;i++){
            for(int j=i+1;j<=n-1;j++){
                for(int k=j+1;k<=n;k++){
                   ans=max(ans,cal(s[i],s[j],s[k]));
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/86504303
今日推荐